Run the code

All questions related to Rifidi Prototyper
skyblue
Posts: 3
Joined: Thu Feb 16, 2012 12:00 pm
Organization: SJTU

Run the code

Post by skyblue » Thu Feb 16, 2012 12:09 pm

Hi,

I successfully ran the code but failed to new a prototype, it shows readerService in MapViewEditor is null.
I wonder if there is some Spring configuration files lost in the svn that cause the problem?

Thanks,
steve

Matt
Posts: 362
Joined: Fri May 02, 2008 11:56 am
Organization: Pramari

Re: Run the code

Post by Matt » Thu Feb 16, 2012 6:50 pm

Hi skyblue,

Go to "run configuration" and press "validate bundles". Are there any problems? Does "add required bundles" help any?

-Matt

skyblue
Posts: 3
Joined: Thu Feb 16, 2012 12:00 pm
Organization: SJTU

Re: Run the code

Post by skyblue » Fri Feb 17, 2012 11:57 pm

Hi,

It shows,
org.rifidi.ui.common.handlers.NewReaderHandler@425eb9 is waiting for {org.rifidi.ui.common.registry.ReaderRegistryService=[org.rifidi.services.registry.ServiceRegistry$DeferredInit@158f1fa, org.rifidi.services.registry.ServiceRegistry$DeferredInit@767286]}
org.rifidi.ui.common.handlers.RemoveReaderHandler@186f3b3 is waiting for {org.rifidi.ui.common.registry.ReaderRegistryService=[org.rifidi.services.registry.ServiceRegistry$DeferredInit@158f1fa, org.rifidi.services.registry.ServiceRegistry$DeferredInit@767286, org.rifidi.services.registry.ServiceRegistry$DeferredInit@e9aa13]}
org.rifidi.prototyper.mapeditor.view.MapViewEditor@4ef630 is waiting for {org.rifidi.ui.common.registry.ReaderRegistryService=[org.rifidi.services.registry.ServiceRegistry$DeferredInit@158f1fa, org.rifidi.services.registry.ServiceRegistry$DeferredInit@767286, org.rifidi.services.registry.ServiceRegistry$DeferredInit@e9aa13, org.rifidi.services.registry.ServiceRegistry$DeferredInit@4ec59]}

Does it means set method is not correctly invoked?
Thanks?

Matt
Posts: 362
Joined: Fri May 02, 2008 11:56 am
Organization: Pramari

Re: Run the code

Post by Matt » Tue Feb 21, 2012 6:32 pm

Hi skyblue,

I'm not entirely sure where that output is from or why you are getting it. Could you post a detailed description of the problems you are getting, what your setup looks like, whether there are any errors, etc? Also make sure you have set the target platform if you haven't. Also, try posting a screenshot of the problem, it would really help out in identifying the issue.

-Matt

skyblue
Posts: 3
Joined: Thu Feb 16, 2012 12:00 pm
Organization: SJTU

Re: Run the code

Post by skyblue » Sat Mar 03, 2012 5:44 am

Hi Matt,

I've solve the problem after setting the target platform.
Many thanks.

-Skyblue

Nérine
Posts: 27
Joined: Wed Apr 29, 2015 6:44 am
Organization: UMMTO

Re: Run the code

Post by Nérine » Wed Apr 29, 2015 8:31 am

Hi,
I'm a student in networks and telecommunications. I want to develope an IDS (Intrusion Detection System) for RFID technologie.
When I download the rifidi repository I don't find org.rifidi.binary, org.rifidi.emulator.taget3.5.2 and org.rifidi.ui.ide.
Then I can't set the org.rifidi.emulator.target as a target platform because there are many missing packages.
Please could you send me web links which allows me to install the complet environnement for developing my application as soon as possible .
Cordialy.
Nérine.

bppause
Posts: 415
Joined: Sat Oct 03, 2009 12:30 am
Organization: Pramari

Re: Run the code

Post by bppause » Fri May 01, 2015 7:55 am


Nérine
Posts: 27
Joined: Wed Apr 29, 2015 6:44 am
Organization: UMMTO

Re: Run the code

Post by Nérine » Sun May 03, 2015 6:35 pm

I followed all the installation steps but I still can not run rifidi edge from source :(

Nérine
Posts: 27
Joined: Wed Apr 29, 2015 6:44 am
Organization: UMMTO

Re: Run the code

Post by Nérine » Mon May 04, 2015 5:08 pm

When I run RififdiEmulator.product I have the following messages on the eclipse console :
Registered org.rifidi.emulator.reader.alien
Registered org.rifidi.emulator.reader.awid
Registered org.rifidi.emulator.reader.epc
Registered org.rifidi.emulator.reader.llrp
Registered org.rifidi.emulator.reader.sirit local
Registered org.rifidi.emulator.reader.symbol
Registered org.rifidi.emulator.reader.thingmagic
log4j:WARN No appenders could be found for logger (org.rifidi.emulator.log.ReaderAppender).
log4j:WARN Please initialize the log4j system properly.
Starting org.rifidi.ui.ide
!SESSION 2015-05-04 22:02:36.713 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_27
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments: -product org.rifidi.ui.ide.product
Command-line arguments: -product org.rifidi.ui.ide.product -data E:\rfid_workspace/../runtime-RifidiEmulator.product -dev file:E:/rfid_workspace/.metadata/.plugins/org.eclipse.pde.core/RifidiEmulator.product/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.osgi 4 0 2015-05-04 22:02:41.685
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Cannot load 64-bit SWT libraries on 32-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:179)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:159)
at org.eclipse.swt.internal.C.<clinit>(C.java:21)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:133)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:516)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at org.rifidi.ui.ide.Application.start(Application.java:21)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
INFO [SpringOsgiExtenderThread-2] (ReaderManagerImpl.java:64) - Setting reader module factories: [org.rifidi.emulator.reader.alien.module.AlienReaderModuleFactory@490342, org.rifidi.emulator.reader.awid.module.AwidReaderModuleFactory@126ba64, org.rifidi.emulator.reader.epc.module.EPCReaderModuleFactory@60b407, org.rifidi.emulator.reader.llrp.module.LLRPReaderModuleFactory@182a033, org.rifidi.emulator.reader.sirit.module.SiritReaderModuleFactory@76f2e8, org.rifidi.emulator.reader.symbol.module.SymbolReaderModuleFactory@1603522, org.rifidi.emulator.reader.thingmagic.module.ThingMagicReaderModuleFactory@423d4f]
Stopping org.rifidi.ui.ide
Shutting down org.rifidi.emulator.reader.alien
Shutting down org.rifidi.emulator.reader.awid
Shutting down org.rifidi.emulator.reader.epc
Shutting down org.rifidi.emulator.reader.llrp
Shutting down org.rifidi.emulator.reader.sirit
Shutting down org.rifidi.emulator.reader.symbol
Shutting down org.rifidi.emulator.reader.thingmagic

bppause
Posts: 415
Joined: Sat Oct 03, 2009 12:30 am
Organization: Pramari

Re: Run the code

Post by bppause » Mon May 04, 2015 9:44 pm

I believe you need to use 32 bit versions of ecslipse and JVM (java 1.7 or less as there are know issues with Java 1.8 with emulator)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest